Service Degradation Due to Region-Wide AWS Outage Affecting the Japan Region

Incident Report for Cornerstone

Resolved

The service disruption impacting the Japan region, including Edge Import, has been fully resolved. All environments are now fully operational.
Posted Apr 15, 2025 - 18:15 PDT

Monitoring

Our engineering teams have applied a fix and we will monitor for a period before considering this incident resolved.
Posted Apr 15, 2025 - 15:51 PDT

Identified

We are beginning to recover in Production. We will continue to share updates until this is fully resolved.
Posted Apr 15, 2025 - 14:09 PDT

Update

Edge Import is now fully operational in Pilot. Our top priority remains restoring Edge Import functionality in Production. We will continue to provide regular updates on our progress.
Posted Apr 15, 2025 - 12:22 PDT

Update

Edge Import remains impacted on Production and Pilot. We are actively investigating the issue as a top priority. We will continue to share regular updates on our progress.
Posted Apr 15, 2025 - 10:29 PDT

Update

Stage environments should now be fully recovered, with no further service degradation expected. For Production and Pilot environments, the impact is currently limited to Edge Import being inaccessible. Our team is actively working to restore access as a top priority.
Posted Apr 15, 2025 - 08:39 PDT

Update

Most services have been restored. Our team continues working on the remaining few to ensure full service recovery.
Posted Apr 15, 2025 - 05:40 PDT

Investigating

We are currently experiencing Service Degradation due to Region-wide AWS outage affecting the Japan region. Clients hosted within Japan may experience intermittent issues.

Our team is actively investigating along with the vendor the issue to identify the root cause. We appreciate your patience as we work towards a resolution.
Posted Apr 15, 2025 - 01:58 PDT
This incident affected: JP SL1 (AWS) (Response Time, Uptime).