As this incident is specific to Stage, we will continue communication through the open Known Issue. All Production environments are currently stable.
Posted Feb 24, 2026 - 13:45 PST
Investigating
We continue to observe reports of increased latency affecting the Stage environment in the UK region.
Our Engineering team is actively investigating the root cause and working to restore normal response times. Further updates will be shared as progress is made.
Posted Feb 24, 2026 - 07:55 PST
Monitoring
The issue has been identified, and services have been restored to normal operations. We will continue to monitor the situation closely.
Posted Feb 24, 2026 - 06:14 PST
Investigating
We are currently investigating reports of increased latency affecting Stage Environment for UK Swimlanes. Users may witness slower page load times and eventually erroring out.
Our Engineering team is investigating on the root cause and is actively working to restore normal response times. We will continue to share updates as progress is made.
Thank you for your patience and understanding.
Posted Feb 24, 2026 - 04:51 PST
This incident affected: UK SL1 (AWS) (Uptime, Response Time), UK SL2 (AWS) (Uptime, Response Time), UK SL3 (AWS) (Uptime, Response Time), and UK SL4 (AWS) (Uptime, Response Time).