Latency on US SL2

Incident Report for Cornerstone

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 13:14 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 12:17 PDT

Identified

Some customers on the US SL2 may experience latency when navigating the application. Our team has identified the cause and is actively working on a resolution. We will provide additional updates as more information becomes available.
Posted Apr 24, 2025 - 12:16 PDT
This incident affected: US SL2 (AWS) (Response Time).