We are planning Emergency Maintenance today at 9:00 PM PT to address this issue. During the maintenance window, the system may be unavailable for up to one hour. Intermittent timeouts may continue until the maintenance is completed. The maintenance is being scheduled outside of peak business hours to reduce overall customer impact. We will continue to provide additional updates as more information becomes available.
Posted Jun 02, 2026 - 10:51 PDT
Investigating
CSOD Engineering teams have detected spikes in intermittent timeouts on the backend, indicating that the issue reported yesterday (01 June 2026) has resurfaced. As a result, some customers on the US swimlanes (SL1, SL2, SL3, and SL5) may witness intermittent timeouts while accessing or navigating the application.
Our Engineering teams are actively investigating the issue and working to restore stability. We will provide another update as soon as additional information becomes available.
Posted Jun 02, 2026 - 07:35 PDT
This incident affects: US SL3 (AWS) (Response Time), US SL5 (AWS) (Response Time), US SL1 (AWS) (Response Time), and US SL2 (AWS) (Response Time).