504 timeout gateway error on Reporting 2.0 (US Swimlanes 1,2 and 5)

Incident Report for Cornerstone

Resolved

Our Engineering Team has confirmed the issue to be resolved.

We will share a Root Cause Analysis in 7-10 business days.

Thank you!
Posted Sep 22, 2026 - 06:41 PDT

Investigating

A production incident occurred in the US PROD environments, causing intermittent issues with Reporting 2.0 services across multiple swimlanes. The CSX application was impacted, experiencing degraded performance and access challenges to the reports.

Our engineering are actively investigating this issue. We will keep you posted on any significant updates.

Thank you for your patience and understanding!
Posted Sep 22, 2026 - 05:20 PDT
This incident affected: US SL5 (AWS) (Response Time), US SL1 (AWS) (Response Time), and US SL2 (AWS) (Response Time).