Intermittent Latency and Errors Across Application - US Swimlanes

Incident Report for Cornerstone

Resolved

The CSOD Technology Team observed a service disruption on the US swimlane. Users were intermittently encountering a 504 error when logging into the portal. The issue now stands resolved.
Posted Jul 14, 2025 - 18:28 PDT

Identified

The issue has been identified and our engineering team is working on developing a fix. The issue has been mitigated for now. We will update here once a resolution is in place. This remains a top priority for our team.
Posted Jul 14, 2025 - 16:49 PDT

Update

Our engineering team is continuing to investigate the root issue. We will update here once the problem has been identified. This remains a top priority for our team.
Posted Jul 14, 2025 - 15:40 PDT

Investigating

Some customers on a US swimlane may experience latency and errors intermittently across the application. We are actively investigating the issue as our top priority. We will share regular updates as they become available.
Posted Jul 14, 2025 - 14:11 PDT
This incident affected: US SL3 (AWS) (Uptime, Response Time), US SL5 (AWS) (Uptime, Response Time), US SL1 (AWS) (Uptime, Response Time), and US SL2 (AWS) (Uptime, Response Time).