Minor Issue - Latency - FRA SL1 (EU PRD)

Incident Report for Cornerstone

Postmortem

Incident Summary:
On November 25, users in the FRA PROD environment experienced platform-wide slowness, resulting in delays during login and reduced responsiveness while accessing key features.

Root Cause:
The investigation confirmed that the performance degradation was caused by a configuration setting in the environment that adversely impacted system responsiveness.

Corrective Action:
The misconfigured setting was identified and rectified, restoring optimal platform performance. End-to-end validation was carried out to confirm system stability and seamless user access.

Preventive Measures:
To mitigate recurrence, Cornerstone is taking the following actions:

  • Strengthening configuration management controls to ensure future configuration changes do not negatively influence platform performance.
Posted Dec 03, 2025 - 15:39 PST

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 10:10 PST

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Nov 25, 2025 - 08:05 PST

Investigating

The FRA SL1 swimlane is experiencing some latency issues. Clients with portals in this swimlane may experience delays or issues accessing certain pages in the application. This is our top priority and we are working to resolve the problem as soon as possible. Please check back periodically for additional updates, which will be posted as they become available.
Posted Nov 25, 2025 - 06:30 PST
This incident affected: FRA SL1 (AWS) (Response Time).