The CSOD Technology Team observed a performance degradation affecting the Career Site on this swimlane. The problem began at 6:50am Pacific Time and was resolved at 7:34am Pacific Time. During this time, clients with portals on this swimlane may have experienced issues while accessing the Career Site. After a period of monitoring we are considering this issue resolved.
Posted May 05, 2026 - 16:10 PDT
Monitoring
Our Engineering team has deployed a fix to address this concern. We will continue to closely monitor the situation to ensure stability.
Further updates will be shared through the Known Issue article and Status page. Thank you for your understanding and patience.
Posted May 05, 2026 - 09:57 PDT
Identified
Cornerstone career site is currently unavailable. Users attempting to access the career page are unable to load the site and are encountering an error message stating: “An error occurred while processing your request.”
Our engineering team has identified the issue and is actively working to restore full service. We will keep you posted on significant updates to this concern.
Posted May 05, 2026 - 09:11 PDT
This incident affected: US SL3 (AWS) (Uptime), US SL5 (AWS) (Uptime), US SL1 (AWS) (Uptime), and US SL2 (AWS) (Uptime).