Minor Issue - Latency - US SL1
Incident Report for Cornerstone
Postmortem

On March 5th, 2024, Cornerstone engineers were alerted by internal monitoring tools for latency. Clients hosted in the US SL1 PRD swimlanes may have experienced intermittent latency while accessing their portals.

 

Cornerstone engineers promptly initiated an investigation and troubleshooting process, it was identified that scaling of infrastructure failed due to one of the dependency failure. The immediate resolution was applied as a configuration change to resume scaling.

 

To prevent similar incidents and mitigate future risks, Cornerstone is implementing additional corrective measures by updating the logic of building and maintaining service inventory aimed at proactively preventing the recurrence of such incidents.

Posted Mar 06, 2024 - 23:10 PST

Resolved
The CSOD Technology Team observed a performance degradation affecting this swimlane. The problem began at 7.15a Pacific Time and was resolved at 8.10a Pacific Time. During this time, clients with portals on this swimlane may have experienced slow performance or intermittent errors while accessing the application.
Posted Mar 05, 2024 - 08:27 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2024 - 08:18 PST
Identified
The swimlane is experiencing some latency issues. Clients with portals in this swimlane may experience delays or issues accessing certain pages in the application. This is our top priority and we are working to resolve the problem as soon as possible. Please check back periodically for additional updates, which will be posted as they become available.
Posted Mar 05, 2024 - 07:51 PST
This incident affected: US SL1 (AWS) (Response Time).