Mailspike Temporarily Blacklisted UK Email IP

Incident Report for Cornerstone

Update

We are continuing to work closely with the vendor to obtain confirmation on the IP delisting request. We will provide the next update as soon as we receive any new information.
Posted Jul 09, 2026 - 08:53 PDT

Update

We are continuing to work closely with the vendor to obtain confirmation on the IP delisting request. We will provide the next update as soon as we receive any new information.
Posted Jul 09, 2026 - 02:06 PDT

Update

Cornerstone UK's email sending IPs have been temporarily blacklisted by Mailspike, a community-oriented IP reputation authority, due to a high number of email delivery failures originating from certain customer accounts.
During this time, emails may fail to deliver. This is our top priority, and we are working closely with the vendor to resolve the problem as soon as possible. Please check back periodically for additional updates, which will be posted as they become available.
Posted Jul 08, 2026 - 23:58 PDT

Update

We are continuing to work closely with the vendor to obtain confirmation on the IP delisting request. We will provide the next update as soon as we receive any new information.
Posted Jul 08, 2026 - 22:19 PDT

Update

We remain actively engaged with the vendor and are awaiting confirmation on the delisting. We will continue sharing updates as they become available.
Posted Jul 08, 2026 - 19:23 PDT

Update

We remain actively engaged with the vendor and are awaiting confirmation on the delisting. We will continue sharing updates as they become available.
Posted Jul 08, 2026 - 17:22 PDT

Update

We remain actively engaged with the vendor and are awaiting confirmation on the delisting. We will continue sharing updates as they become available.
Posted Jul 08, 2026 - 15:21 PDT

Update

We remain in contact with Mailspike while awaiting confirmation of the delisting. Further updates will be provided in due course.
Posted Jul 08, 2026 - 12:19 PDT

Update

We’re actively engaging with Mailspike and awaiting their reply regarding our delisting request. Regular updates will be provided until the matter is completely resolved.
Posted Jul 08, 2026 - 09:16 PDT

Investigating

Cornerstone UK's email sending IPs have been temporarily blacklisted by Mailspike, a community-oriented IP reputation authority, due to a high number of email delivery failures originating from certain customer accounts.
During this time, emails may fail to deliver. This is our top priority, and we are working closely with the vendor to resolve the problem as soon as possible. Please check back periodically for additional updates, which will be posted as they become available.
Posted Jul 08, 2026 - 07:17 PDT
This incident affects: UK SL1 (AWS) (Uptime, Response Time), UK SL2 (AWS) (Uptime, Response Time), and UK SL3 (AWS) (Uptime, Response Time).