Emergency maintenance has been completed and everything is operational at this time.
Posted Mar 26, 2026 - 14:29 PDT
Update
We are starting the emergency maintenance. During this period, you may encounter a 503 error while trying to access Edge Import. We will continue to provide updates as progress is made.
Posted Mar 26, 2026 - 12:31 PDT
Identified
We are aware of an issue causing some Edge Import loads and feeds to fail during processing on US swimlanes. To address this, we will be initiating an emergency maintenance shortly.
We are allowing all currently processing jobs to complete before maintenance begins. In the meantime, new Edge Import and Bulk API jobs are being temporarily prevented from entering the queue.
Once maintenance is complete, new jobs and any impacted scheduled jobs will resume processing.
We will continue to provide updates as progress is made.
Posted Mar 26, 2026 - 11:04 PDT
This incident affected: US SL3 (AWS) (Response Time), US SL5 (AWS) (Response Time), US SL1 (AWS) (Response Time), and US SL2 (AWS) (Response Time).