Minor Issue - Latency US SL1
Incident Report for Cornerstone
Postmortem

On February 28th, 2024, Cornerstone engineers were alerted by internal monitoring tools for latency. Clients hosted in the US SL1 PRD swimlanes may have experienced intermittent latency while accessing their portals.

 

Cornerstone engineers were engaged for investigation and troubleshooting and pointed to the throttling issue with one of the API service. This was resolved by optimising the condition and logic for the service calls.

 

To mitigate this situation from occurring in the future and to reduce the risk of a future impact, Cornerstone is actively working internally to review the incident with the application team. Internal optimizations have been discussed with the appropriate development teams to avoid the recurrence of this incident.

Posted Mar 06, 2024 - 23:08 PST

Resolved
The CSOD Technology Team observed a performance degradation affecting this swimlane. The problem began at 10:28 AM Pacific Time on February 28th, 2024 and was resolved at11:02 AM Pacific Timeon February 28th, 2024. During this time, clients with portals on this swimlane may have experienced slow performance or intermittent errors while accessing the application.
Posted Feb 28, 2024 - 10:30 PST