Emails not processed on FRA SL1

Incident Report for Cornerstone

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 11:06 PDT

Monitoring

A fix has been implemented, and the queues are no longer stuck. However, it will take some time to clear the backlog. We are continuing to monitor the queue.
Posted Sep 14, 2026 - 08:58 PDT

Identified

The issue has been identified and engineering is working on restoring the service.
Posted Sep 14, 2026 - 07:09 PDT
This incident affected: FRA SL1 (AWS) (Response Time).