Minor Issue - Latency - UK Swimlanes

Incident Report for Cornerstone

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 17:00 PDT

Monitoring

Our engineering teams have identified the cause and implemented a fix. We've validated that the issue is no longer present. We will monitor for 1 hour before marking this incident resolved.
Posted Jun 17, 2026 - 15:21 PDT

Investigating

The swimlane is experiencing some latency issues. Clients with portals across UK swimlanes may experience delays or issues accessing certain pages in the application. This is our top priority and we are working to resolve the problem as soon as possible. Please check back periodically for additional updates, which will be posted as they become available.
Posted Jun 17, 2026 - 15:07 PDT
This incident affected: UK SL1 (AWS) (Uptime, Response Time), UK SL2 (AWS) (Uptime, Response Time), and UK SL3 (AWS) (Uptime, Response Time).