Intermittent timeouts observed on US Production Environment

Incident Report for Cornerstone

Monitoring

Our engineering teams have confirmed that the issue has been fixed. We are currently monitoring for at least 1 hour before marking the issue resolved.
Posted Jun 01, 2026 - 13:53 PDT

Update

We are actively investigating this issue and will share an update as soon as possible.
Posted Jun 01, 2026 - 12:37 PDT

Investigating

The issue has resurfaced, and customers may again experience intermittent timeouts while accessing or navigating the application. Our Engineering Teams are actively looking into it. Thank you for your patience and understanding.
Posted Jun 01, 2026 - 09:15 PDT

Monitoring

The CSOD Technology Team has confirmed that the issue has been resolved. We are actively monitoring application stability and performance and will keep you informed of any significant updates.
Posted Jun 01, 2026 - 08:09 PDT

Investigating

Some customers on the US swimlanes (SL1, SL2,SL3,SL5) may experience intermittent timeouts while accessing or navigating the application. We are actively investigating the issue and will share another update as soon as more information becomes available.
Posted Jun 01, 2026 - 07:52 PDT
This incident affects: US SL3 (AWS) (Uptime, Response Time), US SL5 (AWS) (Uptime, Response Time), US SL1 (AWS) (Uptime, Response Time), and US SL2 (AWS) (Uptime, Response Time).