Intermittent Errors on Manage Candidates Page - US Swimlanes

Incident Report for Cornerstone

Resolved

The CSOD Technology Team observed a performance degradation affecting this swimlane. The problem began at 11:45 AM Pacific Time and was resolved at 12:55 PM Pacific Time. During this time, clients with portals on this swimlane may have experienced slow performance or intermittent errors while accessing the Manage Candidates page. After a period of monitoring we are considering this issue Resolved.
Posted Mar 30, 2026 - 16:18 PDT

Monitoring

Our engineering teams have implemented a fix and we have recovered. We will monitor for at least an hour before marking this incident resolved.
Posted Mar 30, 2026 - 13:28 PDT

Investigating

Some customers on US swimlanes (US SL1, US SL2, US SL3, US SL5) may be experiencing intermittent errors on the Manage Candidates page. Our team is actively investigating this as a top priority and will provide updates as more information becomes available.
Posted Mar 30, 2026 - 12:38 PDT
This incident affected: US SL3 (AWS) (Response Time), US SL5 (AWS) (Response Time), US SL1 (AWS) (Response Time), and US SL2 (AWS) (Response Time).