Minor Issue - Latency in UK SL3
Incident Report for Cornerstone
Postmortem

On April 5th, 2024 Cornerstone engineers were alerted by internal monitoring tools for latency. Clients hosted in the UK PRD SL3 swimlane may have experienced intermittent latency while accessing their portals.

Cornerstone engineers were engaged for investigation and troubleshooting, and issues pointed to the database blocking. The blocking process was terminated to resolve the issue.

To mitigate this situation from occurring in the future and to reduce the risk of a future impact Cornerstone is actively working internally with the engineering and Internal optimisations have been discussed with the appropriate development teams to avoid the recurrence of this incident.

Posted Apr 17, 2024 - 23:18 PDT

Resolved
The CSOD Technology Team observed a performance degradation affecting this swimlane. The problem began at [02:15 AM] Pacific Time and was resolved at [02:46 AM] Pacific Time. During this time, clients with portals on this swimlane may have experienced slow performance or intermittent errors while accessing the application.
Posted Apr 05, 2024 - 17:00 PDT